Monday, December 21, 2015

Raspberry Pi how to show less info at bootup

You can substantially decrease the amount of info scrolling by on the screen at bootup time by adding the word 'quiet' (without quotes) to the end of the first line of the file /boot/cmdline.txt

Raspberry Pi Custom Splash Screen (blank screen problem)

I followed the instructions found at for a customized splash screen on the Pi. Everything went well, except….at the end of the boot sequence, the splash screen disappeared and all I was left with was a blank screen. I found out (by trying) that I could type the userid and password blindly, followed by startx (also blindly) and then LXDE would appear as normal.

Hunting around on the forums, I found a post that stated that if you were presented with a blank screen after booting, you should try pressing Ctrl+Alt+F2 to get back to a regular console screen. It worked. I hunted around some more for a better solution, but to no avail.

By the way, this problem does not occur if you have it setup so that you automatically startup startx after booting.

Saturday, December 19, 2015

Screen blanking Raspberry Pi B+

I have a Raspberry Pi running headlessly as a display. Therefore, the screen should never blank.

Here's the link where I got the solution to my problem:

User jwzumwalt came up with the post, I'm just repeating it here for my own reference.

The long and the short of it: there are 2 files to be modified


change two settings in /etc/kbd/config


Add these lines to /etc/xdg/lxsession/LXDE/autostart
@xset s noblank
@xset s off
@xset -dpms

Then reboot and test.

Thursday, December 17, 2015

Error 98 Address already in use in Python

Sometimes bottlewebserver in Python on my Raspberry Pi hangs 'for no good reason'. Upon restarting from the LX Terminal window, the above error appears and Bottle Web Server will not start.

I've read Stack Overflow postings where, if you wait for one and a half minutes the port will free up and the server can then be started. This does not seem to happen in my case.

The only way to restart the server, other than a reboot, is to do the following:

$ ps -fA | grep python

The result will then give a line something like this:

root 2130 1 0 11:08 ? 00:00:00 sudo python

Then simply issue:

$ sudo kill 2130
After this the bottlewebserver will start.

Monday, December 14, 2015

Putty network error connection refused

One of my Raspberry Pi’s that performs sump pump depth measurements every 5 minutes works headlessly. Last week it stopped supplying values via the network to my other Pi, which does the reporting via a web page.

So I tried to reach the Pi via putty. Putty responded with “network error connection refused”. This led me to checking cables, and I found that everything was fine. To make a long story short, it turned out that a recent power loss must have caused a corruption within the networking setup of the Pi.

I hooked up a monitor, keyboard and mouse and did a “sudo apt-get update” followed by “sudo apt-get upgrade”, followed by “sudo apt-get upgrade --fix-missing”. Lastly, I reset the SSH keys by issuing “sudo rm /etc/ssh/ssh_host_*” followed by “sudo dpkg-reconfigure openssh-server”.

After this, things were back to normal.

Wednesday, April 01, 2015

PrintIsolationProxy.dll corrupted



I have a notebook computer, ASUS VivoBook S400CA, Intel i5 processor, running Windows 8.1, around 18 months old now.

The computer had been running fine for all this time, of course it is never as fast as you would like it to be, but still…

The other day I wanted to print something (I only use the printer on average about twice a month), and Windows told me I had to install a printer? What??? I clicked on Find Printer in the Printer Settings Box and up pops dialog box telling me the local print spooler service is not running and to turn it on. What??? So I went to services (Click Start and types ‘services.msc’) and sure enough Print Spooler had stopped. I started it, it seemed to run, but after 5 seconds or so, it stopped. What???

To make an extreme long story short, what fixed it is that I ran the sfc utility from within an Administrator’s command window (type ‘command’ from Start and then right click on Command Prompt, then select Run as Administrator). To run sfc, I typed ‘sfc /scannow’. After this command completed (it takes a while), I went to Notepad (any text editor will do) and looked at the log file that sfc created. This files was stored in c:\windows\system32\logs\cbs\cbs.log. Using the Find command, I looked for occurrences of ‘Cannot’, I found 2 (well actually more than 2, but they always pointed to the same 2 files), amstream.dll and PrintIsolationProxy.dll. The ‘cannot’ refers to the fact that sfc found these files to be corrupted, but it couldn’t repair them.

Next, I took a guess and decided to try and replace PrintIsolationProxy.dll with another copy from somewhere else. I downloaded this copy from, ran it through a couple of virus checkers and malware detectors, then renamed the existing version to PrintIsolationProxyOld.dll and popped the new one in its place. Even that is fairly complicated as in order to be able to rename a file, you need to be the owner of it so in the Properties box of this file I had to change that from ‘TrustedInstaller’.

Once the new file was copied to c:\windows\system32, I opened up services again, started the Print Spooler, and voila: it didn’t die after the mandatory 5 seconds went by. Next I tried to print and the printer works again!

I ran virus checkers and malware detectors over the old version, and none of them detected anything untoward. So I can only surmise that Windows Update did something.

I have no idea what amstream.dll does or which process uses it, that is a problem still remaining to be solved.

Ironically, PrintIsolationProxy.dll was added to Windows around 2009 (Vista?), to prevent wayward printer drivers from crashing the print subsystem…..